videocamWeb Data Extraction Summit - September 30th, 2021.
Join some of the greatest minds in web scraping to educate, inspire, and innovate.
Register for free!
Start a new topic

Can't deploy after many attempts, either requirement error or others

Newest message below, my boto3 version is 1.17.87 on my local machine, why the console tells me 1.18.20? Can I just put lib names in requirements.txt and don't specify version?


Step 3/3 : RUN chmod +x /kumo-entrypoint

 ---> Using cache

 ---> 630e5903b514

Successfully built 630e5903b514

Successfully tagged kumo-entrypoint:latest

Entrypoint container is created successfully

>>> Checking python dependencies

Collecting pip<20.0,>=9.0.3

  Downloading https://files.pythonhosted.org/packages/00/b6/9cfa56b4081ad13874b0c6f96af8ce16cfbc1cb06bedf8e9164ce5551ec1/pip-19.3.1-py2.py3-none-any.whl (1.4MB)

Installing collected packages: pip

Successfully installed pip-19.3.1

boto3 1.18.20 has requirement botocore<1.22.0,>=1.21.20, but you have botocore 1.5.8.

boto3 1.18.20 has requirement s3transfer<0.6.0,>=0.5.0, but you have s3transfer 0.1.10.

Warning: Pip checks failed, please fix the conflicts.

{"message": "Dependencies check exit code: 1", "details": "Pip checks failed, please fix the conflicts", "error": "requirements_error"}

{"status": "error", "message": "Requirements error"}


1 person has this question
Login to post a comment