Start a new topic

Deploy fail with empty error message

My deployment started failing for no apparent reason.

We had a successful deploy about 20 hours ago but when we tried to deploy about 5 hours ago the deployments started consistently failing.

We tried deploying both via `shub` and via the Scrapinghub UI. The error message we get at the end of the build attempt is:

`Error: Deploy failed: b''`

Tracking down where the error is thrown takes me (I think) here:

So it looks like a weird request error but since it happens when deploying via the Scrapinghub UI + we tried via `shub` from 2 places on different sides of the world I don't think it has to do with our local network.

Any ideas?


Best Answer

The issue has been resolved.

Never mind, I just noticed that Scrapinghub is having some issues with deployment on so I guess this will be resolved by itself.

That's correct, project deployments are returning 502 due to the incident. Please subscribe for notifications on the incident. Apologies for the inconveniences.


The issue has been resolved.

Login to post a comment