Learn all about the latest trends and best practices in data extraction - Join us at Extract SummitGet tickets
Start a new topic
Answered

Cannot connect to MySQL on RDS

Hi


Firstly thanks for the amazing product for managing our scrapy project.


I am trying to run my spider on scrapy cloud which has a pipeline that stores the scraped items to a database which is hosted on Amazon RDS.


I am always getting the following error 


 

(2003, "Can't connect to MySQL server on 'abcproject.foobar.ap-southeast-1.rds.amazonaws.com' (timed out)")

 


The same project when i run on my machine it works fine.


I want to know what why that connection is not getting through and what I can do in order to run my spiders successfully.


Thanks


Best Answer

Checked with our platform team and we can't connect to your RDS. It can't connect from our Scrapy Cloud servers nor anywhere else. So I would suggest you revise your policy settings.


Is mysql port 3306 opened for external connections? It's likely that you've whitelisted only your IP.

Hi,


No I haven't listed any IP. I have the public policy for my RDS as long as someone have my db user and password

I wonder who have accepted this as a answer. This is not the white listing or port open problem

I did and you can remove the answered flag if the answer does not solve your issue. I will check with our platform team if there's any issues connecting from our nodes to your server.


1 person likes this

Okay Thank you so much

Answer

Checked with our platform team and we can't connect to your RDS. It can't connect from our Scrapy Cloud servers nor anywhere else. So I would suggest you revise your policy settings.

Which RDS your team tried to connect ?


The one in my question or the one in my code ? 


Thanks


Ok Got it ... I found the issue in AWS. Thanks for helping.

The one in your code, but I'm glad you found the issue.

So what was the issue and how did you fix it?

The inbound rules were restricted. I then allowed connections from any source to my MySQL instance.

Login to post a comment